X540-AT2 No Carrier

Alex Merritt merritt.alex at gmail.com
Fri Nov 6 16:22:11 UTC 2015


Booting 10.2 on a Supermicro X10DRi-T with X540-AT2 (10GigE), I am unable
to get a network signal. ifconfig reports "no carrier" as the status (no
lights are blinking). The cable is plugged in, the cable works (booting
Linux gets me an IP), and have tried different end-points (a switch, then
macbook network sharing). pciconf shows both NICs, and the device driver is
loaded with no errors in dmesg.

A search suggests others who have seen this i) didn't plug a cable in, ii)
had a buggy wire, or switch, iii) needed to manually initialize the device
with ifconfig ix0 up, and/or set an IP directly for it to report a carrier
signal, iv) a faulty co-existing NIC existed and needed to be removed, or
v) some of the sysctl queue lengths need to be increased.

I've tried the above, and the board is brand-new. Not sure what else to
look at.


Changing the media type also has no effect:


Did I miss something in the documentation?


More information about the freebsd-questions mailing list