gptzfsboot problem - anyone awake

Per olof Ljungmark peo at
Mon Mar 23 12:25:15 UTC 2015

On 2015-03-23 10:48, Fabian Keil wrote:
> Per olof Ljungmark <peo at> wrote:
>> FBSD 10-STABLE and a Proliant P410 controller
>> Rebuilt world and kernel last night, rebooted tonight:
>> gptzfsboot: error 1 lba 32
>> gptzfsboot: error 1 lba 1
>> gptzfsboot: No ZFS pools located, can't boot
>> As the boot problem with this controller was known when we installed it
>> we have two logical drives and boots from the second to get around it.
>> The box has been upgraded several times during the last four months with
>> out a problem.
> Has the gptzfsboot been updated as well or could it have gotten corrupted?
>> I tried to boot from a memstick with latest 10-STABLE (r280048)
>>> load /boot/kernel/kernel
>>> load /boot/kernel/opensolaris.ko
>>> load /boot/kernel/zfs.ko
>>> set vfs.root.mountfrom="pool-name"
>>> boot
>> But that produced a panic
>> panic:mountroot: unable to (re-)mount root
>> Ideas anyone? I'm out of them just now...
> To boot from a ZFS root, the vfs.root.mountfrom value should
> start with "zfs:".

Yes, that was it, boot from livecd ok now.

What remains to be solved though is why we can not boot the box any 
longer from the array, nothing was changed except the update on the 
21st, before that the OS was updated on the 1st of March without a hinch.


More information about the freebsd-questions mailing list