FreeBSD 9.3 is not recognizing USB 2.0 peripherals (or maybe USB2 bus)

The Lost Admin thelostadmin at
Wed Mar 11 22:43:10 UTC 2015

Hi all,

I’ve got a Zotac Zbox SD-ID12 (Intel Atop D525). According to the vendor specs it’s got 6 USB 2.0 ports. It’s spend the last few years sitting on a shelf running FreeBSD and getting periodic updates/upgrades and little else.

Currently at FreeBSD 9.3-RELEASE-p10.

Recently I decided to make use of some old USB2 hard drives I had lying around and turn the box into a basic NAS for my home network (nothing fancy just NFS). I got the NFS working without a hitch.

I attached the first of the USB 2.0 drives and it seamed really slow. Looking at /var/messages it indicates it’s running at USB 1 speeds:

da0 at umass-sim0 bus 0 scbus4 target 0 lun 0
da0: <WD My Passport 071A 2011> Fixed Direct Access SCSI-4 device 
da0: Serial Number 575851314136305639323030
da0: 1.000MB/s transfers
da0: 953842MB (1953468416 512 byte sectors: 255H 63S/T 121597C)
da0: quirks=0x2<NO_6_BYTE>

Further digging into dmesg suggests to me that FreeBSD is somehow either not finding or not using USB2 drivers.

For the sake of keeping this message short, the full verbose dmesg can be found here -> ; it will expire in one month (April 11, 2015).

I have tried a variety of USB2 devices (CD R/W, usb hard drive, thumb drives). I have confirmed that all are detected and accessed as USB 2.0 devices on Windows 7, Mac OSX. I have also confirmed that Linux (Raspbian on a raspberry Pi) recognized and used the hard drive as a USB2.0 device.

I tried a few different cables just in case.

Also, I have been using FreeBSD since the 1990s and used to be pretty active at helping people on this list (a long time ago).

The Lost Admin
thelostadmin at

More information about the freebsd-questions mailing list