Xorg problems: FIXED

scrat baho-utot at columbus.rr.com
Sun Mar 8 13:11:03 UTC 2015

On 03/07/15 20:53, Warren Block wrote:
> On Sat, 7 Mar 2015, scrat wrote:
>> I have installed FreeBSD 10.0 and updated it to 10.1 using 
>> freebsd-update
> Why not just install 10.1?  It doesn't matter, though.

I had a USB drive already setup with 10.0 before 10.1 came out.
I then used that as practice for updating the base system

>> Ss root entered the following:
>> /bin/sh
>> Xorg -configure > xorg.log 2>&1
> Why?  Always try to run X without an xorg.conf first.  Only create one 
> if necessary.

I did that as to try to fix this problem, more later.


>>      Configuration failed
>> If I then following the book
>> *|Xorg -config xorg.conf.new -retro|*
> So it works with the generated xorg.conf?

After I set the video driver to vesa in the generated xorg.conf it worked.

>> I can not (from the book) do the following:
>> To exit the test, switch to the virtual console used to start it by 
>> pressing *Ctrl*+*Alt*+*F/|n|/* (*F1* for the first virtual console) 
>> and press *Ctrl*+*C*.
>> it simply doesn't work ie I can not go to the term F1 and Ctrl+C to 
>> stop xorg.
> That is because KMS is being used and requires vt(4) to switch back to 
> the console.  Add to /boot/loader.conf:
>   kern.vty=vt

Ok I learned something here.

Adding kern.vty=vt to /boot/loader.conf fixed my issues

>> Continuing I built Xfce4 from ports, configured it to start from the 
>> command line and started it.
>> I cannot simply log out and return to the command line as the display 
>> goes haywire.  To stop the computer I have to open a terminal in xfce 
>> and su to root and issue a poweroff to shutdown.
> This is the same vt(4) issue.

See above fixed it. All working now :)

Need to read up on KMS and vt

The Xorg section of the handbook needs some updating:

Maybe add something that points one to adding the kern.vt line to 

Fix the section on xorg configuration.

The urw-fonts port installs to /usr/local/lib/X11/fonts/urw-fonts 
directory not /usr/local/lib/X11/fonts/URW.
The /usr/local/lib/X11/fonts/URW directory doesn't exist.

Thank you for all your help you have been a tremendous help

You have made my day.

More information about the freebsd-questions mailing list