nfs mounted /tmp vs disk mounted /tmp

Mike Tancsa mike at
Wed Mar 4 16:40:19 UTC 2015

On 3/4/2015 10:38 AM, CyberLeo Kitsana wrote:
> On 03/03/2015 03:54 PM, Mike Tancsa wrote:
>> While trying to test in the lab a migration of disks from an old pci-x
>> arcmrs array to a pcie card, I ran into an odd problem with the cli and
>> raid management daemon.  I would start up the programs and they would
>> immediately exit
>> Looking at the truss output, it seemed to bork soon after it tried to
>> create a file in /tmp. Testing all the same hardware, but then booting
>> from a disk, it worked.  Back to netboot, but this time with /tmp
>> mounted via tmpfs, it also worked.  So it seems there is something about
>> having tmp mounted via nfs that causes the program to die.  The issue
>> seems to be the setting of locks. I am curious, is this something that
>> can be worked around in nfs, or due to the nature of nfs, this is not
>> possible ?  I think I saw this same issue with virtual box in a netboot
>> environment
>> (
> <snip>
>> fcntl(4,F_SETLKW,0x7ffffffcde10)                 ERR#45 'Operation not
>> supported'
> The fcntl(2) manpage says that F_SETLKW is for advisory locking. Does
> your NFS infrastructure support advisory locks? Is lockd(8) running?

Thanks!  Having lockd / statd running did indeed fix the problem for the 
areca client as well as VirtualBox!


Mike Tancsa, tel +1 519 651 3400
Sentex Communications, mike at
Providing Internet services since 1994
Cambridge, Ontario Canada

More information about the freebsd-questions mailing list