'pkg upgrade' wants to install php56

cpet cpet at sdf.org
Mon Mar 2 00:11:45 UTC 2015


On 2015-03-01 16:59, David Newman wrote:
> How to ensure pkg will upgrade php5 modules within the same minor 
> version?
> 
> After updating pkgs on a FreeBSD 10.1-RELEASE-p6 amd64 system, the 'pkg
> upgrade' command wants to install php56 even though all php5 pkgs are 
> on
> 5.4.37. The rest of the commands from the upgrade appear to want to
> upgrade modules from php5-5.4.37 to 5.4.38.
> 
> There's nothing in /etc/make.conf forcing version numbers.
> 
> I don't particularly care which php version runs (well, within 5.4-5.6)
> as long as module versions are consistent. How to ensure that?
> 
> Thanks
> 
> dn
> 
> [dnewman at somehost ~]$ sudo pkg upgrade
> Updating FreeBSD repository catalogue...
> FreeBSD repository is up-to-date.
> All repositories are up-to-date.
> Checking for upgrades (47 candidates): 100%
> Processing candidates (47 candidates): 100%
> The following 41 packages will be affected (of 0 checked):
> 
> New packages to be INSTALLED:
> 	php56: 5.6.6
> 
> Installed packages to be UPGRADED:
> 	php5-zlib: 5.4.37 -> 5.4.38
> 	php5-xmlwriter: 5.4.37 -> 5.4.38
> 	php5-xmlreader: 5.4.37 -> 5.4.38
> 	php5-xml: 5.4.37 -> 5.4.38
> 
> ...
> 
> Installed packages to be REINSTALLED:
> 	php-libawl-0.54 (direct dependency changed)
> 
> The process will require 15 MiB more space.
> 13 MiB to be downloaded.
> 
> Proceed with this action? [y/N]:
> 
> 
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to 
> "freebsd-questions-unsubscribe at freebsd.org"

Read updating default php version has been updated to 5.6 and pkg 
doesn't know this easy fix is in UPDATING.




More information about the freebsd-questions mailing list