help with vnc (what was the right fix) after pkg upgrade FreeBSD 10.1-RELEASE-p10

Ed Hudson elhosots at
Mon Jun 15 19:17:49 UTC 2015

i had a problem with vnc after updating.
the things are tried are 'below' the questions here and basic version info.

FreeBSD version:
FreeBSD bsd1.hoe 10.1-RELEASE-p10 FreeBSD 10.1-RELEASE-p10 #0: Wed May 13
06:54:13 UTC 2015
root at

% pkg info | grep vnc
vnc-4.1.3_10                   Display X and Win32 desktops on remote
X/Win32/Java displays

my question is, what would have been the right fix ?
a second question is, why did this get broken ?
a third question is, was there an easier way to solve the problem ?
(i realize my panic response was excessive and trying to track down the log
file message could have shortcircuited some of my efforts; my guess from
this error message was that somehow a package dependency was missed and
that a complete reinstallation had a good chance of fixing it.  however,
i've been so traumatized in the past around logitechmediaserver / perl CPAN
hell that i was left with the massive reinstall paradigm as a way of
sometimes fixing package version issues).


this weekend i did a freebsd-update, pkg update, pkg upgrade, portsnap
fetch, etc.

after updatding, i rebooted the machine, and then tried to relaunch my vnc
only to find errors RE fontpath / fixed:
***(from .vnc/*.log):
error opening security policy file /usr/local/lib/X11/xserver/SecurityPolicy
Could not init font path element /usr/local/lib/X11/fonts/Speedo/, removing
from list!
Could not init font path element /usr/local/lib/X11/fonts/CID/, removing
from list!

Fatal server error:
could not open default font 'fixed'
xhost:  unable to open display...

to try to fix the problem i tried, in the following order, and to no avail:
pkg remove vnc
pkg install vnc
(no success)
pkg info | awk '{print $1}' > t.t
pkg remove `cat t.t`
(remove all packages)
pkg install xorg
pkg install vnc
(still no success).
cd /usr/ports/*/vnc
make install (and again after setting FORCE_PKG_REGISTER)

finally, i hand edited the 'vncserver' script in /usr/local/bin (after
seeing what the make install had touched in /usr/ports/*/vnc/work, and
noticing a 'vncserver.bak'), and uncommented the 'cmd=' lines
that mentioned -fp (mostly because it in 'vncserver' script but commented):

$cmd .= " -fp /usr/lib/X11/fonts/misc/,/usr/lib/X11/fonts/75dpi/";

this of course didn't work, and a quick 'find' in /usr/local for '*eedo*'
showed that there were now Speedo fonts in /usr/local/share.    i then
added the following line:

$cmd .= " -fp

and now everything works  (AT LAST, SUCCESS!)

but what is the 'right' fix ?

More information about the freebsd-questions mailing list