Can not get Realtek RTL8188CU USB adapter to work on 10.2-BETA1 laptop

Ian Smith smithi at
Sat Jul 18 18:22:02 UTC 2015

In freebsd-questions Digest, Vol 580, Issue 6, Message: 6
On Fri, 17 Jul 2015 11:22:28 -0400 William Bulley <web at> wrote:

 > I have a new laptop with an Intel core i7-5600U CPU running 10.2-BETA1 FreeBSD.
 > I tried following the directions here:
 > and I tried the directions in the "% man 4 urtwn" man page:
 >      To compile this driver into the kernel, place the following lines in your
 >      kernel configuration file:
 >            device ehci
 >            device uhci
 >            device ohci
 >            device usb
 >            device urtwn
 >            device wlan
 >      Alternatively, to load the driver as a module at boot time, place the
 >      following line in loader.conf(5):
 >            if_urtwn_load="YES"
 >      In both cases, place the following line in loader.conf(5) to acknowledge
 >      the firmware license (see below):
 >            legal.realtek.license_ack=1
 >   [[I did both: rebuilt kernel AND added two lines to the /boot/loader.conf file]]

What Kevin said, I expect, but I'm a sucker for a splendid bug report :)

It does say 'Alternatively', and I'd expect to see something in dmesg 
about failure to load the module, being already in kernel.  Which may 
not matter here, but I'd expect kldstat -v to show urtwn in kernel.

cheers, Ian

More information about the freebsd-questions mailing list