portmaster -af fails due to dead port - HELP

William F. Dudley Jr. wfdudley at gmail.com
Fri Jul 3 00:22:23 UTC 2015

So, this happened:

prompt> portmaster -af -x arj -x faad2 -x libutempter -x ruby -x tcl

(lots of output deleted)

===>>> Returning to update check of installed ports

         ===>>> No origin available for tcl~pkg-renamed~9E62-8.4.19_3,1

===>>> Cannot continue
===>>> Aborting update

SO I try to delete the package.
I'd already tried "pkg delete tcl" and gotten "Package(s) not found!", 
so now this:

prompt> pkg delete tcl~pkg-renamed~9E62-8.4.19_3,1
Checking integrity... done (0 conflicting)
Package(s) not found!

So portmaster is complaining about tcl, but tcl isn't installed, and -x 
doesn't work either.

How do I get past this monster?

Bill Dudley

On 07/02/2015 05:46 PM, Herbert J. Skuhra wrote:
> On Thu, Jul 02, 2015 at 05:20:19PM -0400, William Dudley wrote:
>> That got me a lot further, but now the problem is this:
>> ===>>> All >> arj-3.10.22_4 (61/61)
>> ===>>> Currently installed version: arj-3.10.22_4
>> ===>>> Port directory: /usr/ports/archivers/arj
>> ===>>> Launching 'make checksum' for archivers/arj in background
>> ===>>> Gathering dependency list for archivers/arj from ports
>> ===>>> Forcing update for /usr/ports/devel/autoconf
>> ===>>> Launching child to reinstall autoconf~pkg-renamed~FEE5-2.69
>> ===>>> All >> arj-3.10.22_4 >> autoconf~pkg-renamed~FEE5-2.69 (62/62)
>> ===>>> No valid installed port, or port directory given
>> ===>>> Try portmaster --help
>> ===>>> Update for autoconf~pkg-renamed~FEE5-2.69 failed
>> ===>>> Aborting update
>> ===>>> Update for arj-3.10.22_4 failed
>> ===>>> Aborting update
>> I don't understand if this is a problem with arj or autoconf, but I don't
>> want to delete arj, because
>> other packages depend on it, and I don't want to delete them.  I tried "pkg
>> lock arj" and that didn't
>> seem to do anything, in that portmaster -af still wants to upgrade arj.
> What's the output of 'pkg version -x autoconf'? Try to remove those
> packages first and then run portmaster again!

More information about the freebsd-questions mailing list