ZFS replacing drive issues

William A. Mahaffey III wam at hiwaay.net
Mon Jan 5 01:01:12 UTC 2015

On 01/04/15 18:25, Da Rock wrote:
> I haven't seen anything specifically on this when googling, but I'm 
> having a strange issue in replacing a degraded drive in ZFS.
> The drive has been REMOVED from ZFS pool, and so I ran 'zpool replace 
> <pool> <old device> <new device>'. This normally just works, and I 
> have checked that I have removed the correct drive via serial number.
> After resilvering, it still shows that it is in a degraded state, and 
> that the old and the new drive have been REMOVED.
> No matter what I do, I can't seem to get the zfs system online and in 
> a good state.
> I'm running a raidz1 on 9.1 and zfs is v28.
> Cheers
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to 
> "freebsd-questions-unsubscribe at freebsd.org"

Someone posted a similar problem a few weeks ago; rebooting fixed it for 
them (as opposed to trying to get zfs to fix itself w/ management 
commands), might try that if feasible .... $0.02, no more,l no less ....


	William A. Mahaffey III


	"The M1 Garand is without doubt the finest implement of war
	 ever devised by man."
                            -- Gen. George S. Patton Jr.

More information about the freebsd-questions mailing list