generating xorg.conf does not work

doug at doug at
Fri Aug 28 19:17:33 UTC 2015

On Fri, 28 Aug 2015, lokadamus at wrote:

> On 08/28/15 06:56, doug at wrote:
> ...
>> around the first of this month, the handbook still had generating
>> xorg.conf the "tried and true" way: Xorg -configure. This did not work
>> but letting xorg self configure did (and does) work. I am currently
>> running xfce-4.12_1.
>> I have installed several ports that say add this font or make some other
>> change to xorg.conf. And, perhaps have a problem running chrome because
>> I am not able to do that. So my questions are basically: should this be
>> posted to xorg; are there any guidelines on how to build an xorg.conf
>> from the various outputs from the self-generated start; is auto
>> generation the way to go or not; and lastly if auto-generation is the
>> way of the future how do you add fonts and or change the other things
>> one usually does?
> I'm a little bit confused.
> Generated your xorg.conf and look at your /var/log/Xorg.log to see, what
> is wrong.
> What error message are in Xorg.log? Else you can configure it and look
> what is going wrong.

Maybe I should have taken the questions one at a time. My highest priority 
question is that the handbook is in error on how to generate xorg.conf.
startx is just not correct.

The next issue (Xorg -confgure), I only noted in passing. My question here is 
this a FreeBSD issue or should it be PR'd to Xorg. For starters 'Xorg 
-configure' selected the vesa driver, autoconfiguration picked the ATI Radeon 
driver. The vesa driver could not negociate a setting. Note even if it did the 
screen resolution would be 1026x760 or whatever the current one-size fits all 
resolution is. This is clearly an error in the Xorg command. There may have been 
other errors in the generated xorg.conf file, but the first one was the vesa 
driver could not get something out of the BIOS it liked. Earlier versions of 
Xorg this all worked albeit with the vesa driver.

Sadly I did not have the earlier working xorg.conf because I accidently wiped 
out /etc. In recovering the data I forgot about the copy in /root.

Douglas Denault
doug at
Voice: 301-217-9220
   Fax: 301-217-9277

More information about the freebsd-questions mailing list