Owncloud Client won't start

Christian Baer cb at icerats.de
Sun Aug 9 15:51:42 UTC 2015

Hi everybody!

First off, if someone thinks this discussion should be on the ports mailing-
list, please let me know and I will move it there.

After getting the Owncloud client installed at last[1], I promptly ran into 
another problem:

christian at obelix:~ % owncloudcmd 
/usr/local/lib/libpng16.so.16: version PNG16_0 required by \
/usr/local/lib/libQt5WebKit.so.5 not defined

The same thing happens when I try to start the GUI-client.

This is on:
FreeBSD 10.1-RELEASE-p16 amd64
With the GENERIC kernel.

After torturing $SEARCHENGINE for quite a while, I had not found anything that 
relates to this problem in combination with owncloud. The problem does not 
seem to be FreeBSD-specific, because the first couple of hits I got were from 
people having this problem with RPM-installs (but no mention of OC). There was 
one account of someone with this problem on FreeBSD with Stellarium.

After some further reading, I found several people who attributed this effect 
to problems with Qt 4/5. Most of the Software on my machine is still Qt 4 
based because I set up this computer when KDE5 was not really ready for 
production systems.

The only real solution that anyone offered (and I found) was a general pkg 
upgrade. The claim was that pkg install were not "agressive" enough in 
updating required packages und thus some packages were not updated although 
they should have been.

I updated the system (as uname states) and the packages:
root at obelix:/usr/local/etc/rc.d # pkg upgrade -n
Updating FreeBSD repository catalogue...
FreeBSD repository is up-to-date.
All repositories are up-to-date.
Checking for upgrades (549 candidates): 100%
Processing candidates (549 candidates): 100%
Checking integrity... done (4 conflicting)
pkg: Cannot solve problem using SAT solver:
pkg: cannot find qt4-mysql-plugin in the request
pkg: cannot solve job using SAT solver
Checking integrity... done (0 conflicting)
Your packages are up to date.

I have serious doubts that the mysql-plugin is the problem here. pkg complains 
that the same version is installed as there is on the server (both 4.8.6)[2]:

This however did not get rid of the initial problem, meaning I still get the 
same error message.

Has anyone else encountered this and found a solution?


[1] Please don't ask, this was not my brightest moment. :-)
pkg: Cannot solve problem using SAT solver:
dependency rule: package akonadi(r) depends on: qt4-mysql-plugin(r)qt4-mysql-
dependency rule: package akonadi(l) depends on: qt4-mysql-plugin(r)qt4-mysql-
upgrade rule: upgrade local qt4-mysql-plugin-4.8.6 to remote qt4-mysql-
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 343 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20150809/397513b1/attachment.bin>

More information about the freebsd-questions mailing list