windows entry for grub2

David Benfell benfell at
Thu Aug 6 08:13:14 UTC 2015

Quoting Cary <cary at>:
> That's all.  If you've got it, that will be nice to hear.

It was weird. In the past, when I've run into difficulty with EFI boot  
entries, efibootmgr (under Linux) has been my friend. This tool can  
add boot entries, change the order in which they are attempted, delete  
boot entries, and probably a few other things.

So when grub was still missing, I booted into Linux, ran efibootmgr,  
added the entry and tried again. The invocation is very specific. You  
specify the drive *and* the partition the efi file is in.

No joy. Any entries I added disappeared by the reboot. And just so  
we're clear, rebooting to Linux and running efibootmgr confirmed that  
the entries had disappeared.

So I got a Windows recovery disk and tried getting *it* to fix the  
boot. I tried just about every option there was on that thing. Still  
no joy. It flatly refused.

As to your specific points, the system didn't just come with Windows.  
Dell adds a bunch of partitions with various utilities and recovery  
programs. But there didn't seem to be any way to access them--unless I  
got grub running. Some of those partitions are msdosfs and I'm pretty  
sure that's what grub-mkconfig was responding to.

David Benfell <benfell at>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: PGP Digital Signature
URL: <>

More information about the freebsd-questions mailing list