Latest 'freebsd-update' - 10.1-RELEASE-p16 kernel module mismatch?

Karl Pielorz kpielorz_lst at
Wed Aug 5 10:09:13 UTC 2015


I just updated my amd64 10.1-RELEASE-p10 system to 10.1-RELEASE-p16.

This replaced the kernel, and some modules. After a reboot though - I can't 
load the 'geom_eli' module (actually, I can't load it's required 
'crypto.ko' module more specifically) any more e.g. :

# kldload geom_eli
kldload: an error occurred while loading the module. Please check dmesg(8) 
for more details.

Looking at dmesg, I can see:

link_elf_obj: symbol db_show_table undefined  <--- this is crypto.ko
linker_load_file: Unsupported file type       <--- trying to load
KLD geom_eli.ko: depends on crypto - not available or version mismatch
linker_load_file: Unsupported file type

The first two lines are from the system trying to chain-load 'crypto.ko' 
for geom_eli (as it's a requirement) - but that fails to load, and then 
geom_eli fails (because crypto.ko failed to load).

This a known issue?

I have source on this box (which also got updated by freebsd-update) - so I 
tried building GENERIC, and loading the resultant 'crypto.ko' file - but 
that nets the same error.


More information about the freebsd-questions mailing list