mis-match library in 10.1 octave/g++48 package

Jin Guojun jguojun at sbcglobal.net
Thu Apr 2 07:12:16 UTC 2015

I installed octave-3.8.2 and compiled code but got run time error as following:
g++48 octave-c-api.c -I/usr/local/include/octave-3.8.2/octave -I/usr/local/include -L/usr/local/lib/octave/3.8.2 -loctave -lpcre 

/lib/libgcc_s.so.1: version GCC_4.6.0 required by /usr/local/lib/gcc48/libgfortran.so.3 not found
GNU C library often cause such problem, but it is not clear why gcc 4.8 requires 4.6 library.Does anyone know how to solve this problem?
Current octave package requires gnu c++ (g++) to build, and native BSD c++ does not work on this build.I wonder if octave can be built by BSD C/C++ compiler instead of G++ to avoid such problem in future.
Also, since 10.1-R use pkg to fetch/install packages from a centralized repository, and package is keeping to update to the latest release, some mechanism needs to be used to insure the library will match.

More information about the freebsd-questions mailing list