sysinstall fails to fetch; pkg install succeeds

Ian Smith smithi at
Fri Nov 21 16:36:24 UTC 2014

In freebsd-questions Digest, Vol 546, Issue 3, Message: 7
On Tue, 18 Nov 2014 22:10:12 -0700 Gary Aitken <freebsd at> wrote:

 > I'm in the process of installing a 9.3 system.
 > "pkg install foo" seems to work fine, fetching from the network.
 > However, if I run sysinstall (forgot to include the handbook), it fails
 > when trying to fetch from the network.  I've tried both FTP mode and
 > FTP through firewall mode.  What does sysinstall do that's different when 
 > trying to fetch from the network?

sysinstall only knows about the old pkg_tools (pkg_add etc) which have 
been defunct for quite a while.  I don't know why the pkg_* binaries are 
even left in place (let alone executable) on pkg(8)-using systems, as I 
found out the hard way after pkg2ng'ing 9.2R, then ungrokingly running 
the old not-yet-pkg-aware portmaster, managing to make quite a mess.

For anyone running an 8.x or 9.x system using pkg(8) exclusively, maybe 
via pkg2ng, I'd recommend considering - if rm seems drastic - at least:

 # chmod a-x /usr/sbin/pkg_*

Try bsdconfig(8) which I think still (re)installs the docs, and provides 
a (working?) front end for installing packages.  Let's know how it goes?

bsdconfig provides most if not all 'post-installation' functions from 
sysinstall, similar look'n'feel to bsdinstall (invoked for disk setup).

 > This is going through a firewall running natd and ipfw, so it may be a
 > firewall rule problem.  But I would have thought they would either both
 > fail or both succeed.

sysinstall still has a use on 9.x, but package installation isn't it :)

cheers, Ian

More information about the freebsd-questions mailing list