msk doesn't work under 10-amd64 but does on i386

Alnis Morics alnis.morics at
Sat Nov 15 17:44:00 UTC 2014

 >Hello list,
 >I have a notebook machine that I've converted to act as a small
 >low-power server because its hinges have worn out. It's an atom samsung
 >notebook. The cpu identifies as:
 >Intel(R) Atom(TM) CPU N450   @ 1.66GHz
 >it is 64-bit capable:
 >Extended feature flags set 1 (CPUID.80000001H:EDX): 20000000
 >EM64T     Intel Extended Memory 64 Technology
 >so I installed the 10.1-R amd64 memstick. All goes well, it reboots, I
 >ssh into it and things are fine for a few minnutes but then I get the
 >following at the console:
 >mmsk0: watchdog timeout
 >and I lose the connection, can't ping anything including its gateway
 >from the device. A reboot will restore connectivity for a short period
 >but the same thing happens again. I tried with the latest 11 snapshot
 >and also tried with 10.0-R amd64 and get the same result. Then I tried
 >with the 10.1-R i386 (in other words, 32 bit) memstick and everything
 >works fine.
 >Why the difference?

The same problem here, with the same netbook. AFAIK, it's an issue with 
Marvell Technologies NICs; there are some PRs 
( For me, 9.x 
realeases and 10.1-RC3 worked well with this NIC but 10.0-RELEASE and 
10.1-RELEASE don't. Some people have fully or partially solved this 
problem with other Marvell NICs by tweaking some kernel settings. I, 
too, tried them but thtey didn't help.


More information about the freebsd-questions mailing list