write-protected usb flash drive

Polytropon freebsd at edvax.de
Sat May 24 15:41:07 UTC 2014

On Sat, 24 May 2014 16:22:59 +0100, Arthur Chance wrote:
> OK, thought I'd better try my own advice rather than just handing it 
> out. I put a microSD card out of an old phone into a SanDisk mSD -> SD 
> adapter and plugged that into my SanDisk SD -> USB adapter, mounted it 
> (FAT32 file system already on it) and wrote a file to it. Worked as 
> you'd expect. I then unmounted and unplugged it, flipped the write 
> protect switch and tried to remount. Result was
> mount_msdosfs: /dev/da5s1: Input/output error
> Mounting it read-only was fine. So, the write protect is honoured by at 
> least some SD -> USB adapters.

This is already on file system level. It _should_ work the same
at upper layers, for example when using dd to write NULs to the
device with the write protection on - an error should (correctly)
occur in that case.

When a r/o mount is forced, the routines accessing that file
system cannot avoid the write protection. Still writes are
possible _aside of_ the file system which should be prevented
by the switch as well. It's probably a good idea to check that
too, e. g. put in the card with write protection on and then
try dd or newfs on it.

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list