frequent panics on 9.2-RELEASE (and now shutdown failure)

Will Parsons varro at nodomain.invalid
Wed May 21 19:32:02 UTC 2014

Will Parsons wrote:
> Thomas Hoffmann wrote:
>> On Mon, May 19, 2014 at 5:51 PM, Will Parsons <varro at nodomain.invalid>wrote:
>>> A few days ago, I started to get frequent panics on a laptop running
>>> 9.2-RELEASE.  The message is:
>>> panic: ffs_valloc: dup alloc
>>> and the backtrace from the core.txt file is:
>>> KDB: stack backtrace:
>>> #0 0xc0b1810f at kdb_backtrace+0x4f
>>> #1 0xc0adf38f at panic+0x16f
>>> #2 0xc0d102d4 at ffs_valloc+0x5a4
>>> #3 0xc0d50384 at ufs_makeinode+0xa4
>>> #4 0xc0d50c80 at ufs_create+0x30
>>> #5 0xc0f73b02 at VOP_CREATE_APV+0xa2
>>> #6 0xc0b8e3f6 at vn_open_cred+0x246
>>> #7 0xc0b8e87b at vn_open+0x3b
>>> #8 0xc0b89ccc at kern_openat+0x1ec
>>> #9 0xc0b8a0e5 at kern_open+0x35
>>> #10 0xc0b8a120 at sys_open+0x30
>>> #11 0xc0f4ce53 at syscall+0x443
>>> #12 0xc0f36661 at Xint0x80_syscall+0x21
>>> Uptime: 7m7s
>>> Physical memory: 2965 MB
>>> Dumping 160 MB: 145 129 113 97 81 65 49 33 17 1
>>> I don't really have any experience with FreeBSD kernel dumps, so I
>>> don't know how to pick out what's important.  How do I proceed to
>>> resolve this problem?
>>> (Also note that I have 9.1-RELEASE installed on the same machine on a
>>> different slice which is stable, so I think hardware problems are not
>>> likely to be a factor.)
>> Have you tried booting into single user mode and running fsck -y on your
>> UFS filesystems? If you have journaling enabled, I think the recommendation
>> is to run fsck -y twice on each UFS filesystem.
> I think one time I booted into single user mode for the fsck, but I
> was not aware of using it twice.  Other times, I've booted into the
> stable 9.1 system on the other slice and run fsck from there.  I've
> tried it both with the -y option and without, responding n to the
> option to use the journal, since it looked like the fsck was doing a
> more thorough job if I didn't use the journal (but I don't really know
> the implications of using the journal vs. not with fsck).

In the last few days, the problem of the frequent panics seems to have
disappeared, only to be replaced by another serious problem:

When I do a shutdown, the system freezes, i.e., the X-session
terminates and is replaced with a completely black screen with a
cursor in the upper left.  There are no shutdown messages and the only
thing to do is to cause a forced power-down (resulting, of course, in
needing to do complete fsck's after rebooting).


More information about the freebsd-questions mailing list