long string using find and "-exec ls -ls" to find part-of filename

Gary Kline kline at thought.org
Mon Jun 30 06:07:58 UTC 2014

Organization: Thought Unlimited.  Public service Unix since 1986.
Of_Interest: With 27++ years  of service  to the  Unix  community.

On Mon, Jun 30, 2014 at 01:48:01PM +0800, Gregory Orange wrote:
> On 30/06/14 13:24, Gary Kline wrote:
> >On Mon, Jun 30, 2014 at 01:04:50PM +0800, Gregory Orange wrote:
> >>How about this?
> >>find . -name foo.tar -o -name foo.tgz -o -name foo.tar.gz|xargs ls -lsi
> >	yup.  then WHY O WHY O WHY doesnt this work::
> >	find . -name "foo.t*" |xargs ls -lsi
> >	work?  is it only my memory [[delusional] that made me think that
> >	"foo.t*" expanded into your cmd string??  I thought the "*"
> >	expanded into what you have to save the hacker typing/keystrokes.
> Curiously your command line works for me on both an Ubuntu (sh,
> bash) machine and a FreeBSD (sh, bash, csh, tcsh) machine. I would
> have expected the shell to expand * to and cause find to return an
> error, but it appears not. Perhaps it depends on the shell? It works
> for me on the shells listed above.

	this is bloody bizzarre.  the first//Only first time, your cmd 
	worked.  ive used zsh since 1989 when I ported it to my 80286. 
	I Still use zsh.  but as-is [zsh], it still only works the first
	time.  even with O's parens, no diff.  I'm gng to try typing 
	bash[it] and see.   WHY your oneliner worked once, not even 
	all the gods in hhell know.   

just FWIW:

5436  find . -name "vbc.t*" -print exec `ls` {} \;
5437  cbin
5438  rgr find
5439  find . -name "vbc.t*" -print |xargs ls -l

	from 65mins ago, the abv, here on "tao"

 	ive got ubuntu 14.04 here; freeebsd and backup on my server;
	and a 'ripoff' redhat on my used 2cpu [unsed] desktop.
	here, tao, is where I live and hack.

 Gary Kline  kline at thought.org  http://www.thought.org  Public Service Unix
             Twenty-seven years of service to the Unix community.

More information about the freebsd-questions mailing list