10.0 bsdlabel returns an error

Warren Block wblock at wonkity.com
Wed Jun 25 15:58:20 UTC 2014

On Wed, 25 Jun 2014, Bertram Scharpf wrote:

> Hi,
> I tried to find out how large the partitions on my main hard disk
> are. But then:
>  # bsdlabel ada0s2
>  bsdlabel: /dev/ada0s2 read: Invalid argument
>  # bsdlabel ada0s3
>  bsdlabel: /dev/ada0s3 read: Invalid argument
>  # uname -rs
>  FreeBSD 10.0-STABLE
>  # mount | grep ada0s2 | wc -l
>         0
> I remembered that I solved an earlier label issue on an other
> machine by booting 9.2 from a USB stick. This helped me here, too.
> Still, I want to know why the 10.0 "bsdlabel" doesn't work.

Because the default partitioning method of 10.0 and later is GPT. 
Wikipedia has a nice entry on it:

FreeBSD shows the partitions on a GPT disk as p1, p2, and so on.

gpart(8) can show and edit these partitions, and MBR partitions, and 
others.  Use it in preference to the old fdisk and bsdlabel.

This article shows how to use gpart to partition disks with GPT or MBR:

More information about the freebsd-questions mailing list