10.0 bsdlabel returns an error

Polytropon freebsd at edvax.de
Wed Jun 25 13:19:43 UTC 2014

On Wed, 25 Jun 2014 14:58:30 +0200, Bertram Scharpf wrote:
> Hi,
> I tried to find out how large the partitions on my main hard disk
> are. But then:
>   # bsdlabel ada0s2
>   bsdlabel: /dev/ada0s2 read: Invalid argument
>   # bsdlabel ada0s3
>   bsdlabel: /dev/ada0s3 read: Invalid argument
>   # uname -rs
>   FreeBSD 10.0-STABLE
>   # mount | grep ada0s2 | wc -l
>          0
> I remembered that I solved an earlier label issue on an other
> machine by booting 9.2 from a USB stick. This helped me here, too.

In current FreeBSD versions, the "traditional tools" of fdisk
and bsdlabel are considered deprecated. Partitioning should
be done with gpart, and if possible, GPT is preferred over MBR
style. Maybe you can achieve better results with using the
corresponding gpart commands?

> Still, I want to know why the 10.0 "bsdlabel" doesn't work.

Maybe it's on the same way as sysinstall? :-)

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list