Mounting NTFS on 10.0-RELEASE

Tijl Coosemans tijl at
Thu Jan 23 12:42:07 UTC 2014

On Wed, 22 Jan 2014 21:20:43 +0000 Frank Leonhardt wrote:
> On 22/01/2014 11:53, Tijl Coosemans wrote:
>> On Tue, 21 Jan 2014 18:52:34 +0000 Frank Leonhardt wrote:
>>> I new I was in for trouble when mount_ntfs wasn't found...
>>> Okay, I need to mount an NTFS volume on FreeBSD 10.0 (on ZFS if it
>>> matters). Unfortunately there doesn't look to be an NTFS module any
>>> more. 'sfunny, as I thought putting FUSE in the base system was supposed
>>> to interface to anything. It probably does, but I just don't know how
>>> and I'm in a hurry. Reading the obvious manual pages isn't any help, so
>>> I need a non-obvious one, no doubt. As this has whole FUSE business has
>>> been in flux, all the pages I Google are out-of-date.
>>> I might suggest that when commands like mount_ntfs are removed for the
>>> base that they be replaced by a script to print out some help.
>> Try the sysutils/fusefs-ntfs port.
> Thanks! That's just what I needed - I tried looking for a port and 
> couldn't find it.
> I just compiled it, but it said...
> ================================================================
> *** Error code 70
> Stop.
> make[1]: stopped in /usr/ports/sysutils/fusefs-ntfs
> *** Error code 1
> Stop.
> make: stopped in /usr/ports/sysutils/fusefs-ntfs
> ================================================================
> I'd tried using sysutils/ntfsprogs earlier (amongst a LOT of other 
> things) and it looks like they're not friends. I *did* try to find the 
> ntfs-3g port - should have guessed it was actually called fusefs-ntfs.
> For anyone else looking for the solution, DON'T install 
> sysutils/ntfsprogs (or if you do, "make deinstall"), and do build 
> sysutils/fusefs-ntfs.
> Then don't kid yourself that mount_ntfs is going to work :-)
> What does work is:
> Add 'fusefs_enable="YES"' to /etc/rc.conf
> Add 'fuse_load=YES' to /boot/loader.conf
> Reboot and then mount your USB NTFS volume thus:
> ntfs-3g /dev/da0s1 /mnt
> Obviously altering da0s1 to suit.
> I'm not 100% sure that the lines in rc.conf and loader.conf are 
> necessary but the machine's busy and I can't reboot it to find out. I 
> shall document this at some point, when I've figured out how to get it 
> to work the old way - i.e. mount_ntfs - but I'm posting this here in 
> case anyone else has having the same trouble. Incidentally, mount -t 
> ntfs-3g... doesn't do it.

There's mount_fusefs.

More information about the freebsd-questions mailing list