pkg: What am I doing wrong?

Ross basarevych at
Thu Jan 23 10:04:53 UTC 2014

When I tried to install anything on a fresh FreeBSD 10 pkg failed. OK, I
googled the topic. Main repository is half empty at the moment for some
reason. I added another repo by creating /etc/pkg/release-0.conf:

release-0: {
  url: "pkg+${ABI}/release/0",
  mirror_type: "srv",
  signature_type: "fingerprints",
  fingerprints: "/usr/share/keys/pkg",
  enabled: yes

So, now I have two repos: the main one and the release repo. Tried to

pkg install kde

After downloading the packages it failed because of conflicts. Apparently
it mixed main repo packages with the release repo and died. OK, run this

pkg install -r release-0 kde

At last! Everything went well and now I have a KDE desktop. But what next?
I want to run "pkg upgrade" some time later and have all the packages
installed from the release repo to be updated to the latest version.

At the moment, after "pkg upgrade" I get a list of packages to be upgraded
and when I say "yes" pkg dies with errors like this (a lot of errors like

pkg: WARNING: locally installed qt4-webkit-4.8.5 conflicts on
/usr/local/share/qt4/mkspecs/modules/qt_webkit_version.pri with:
        - qt4-webkit-4.8.5_1

So how do I upgrade? Am I doing something wrong?

More information about the freebsd-questions mailing list