9.2-RELEASE kernel ignores MBR on boot disk

Scott Bennett bennett at sdf.org
Sun Jan 12 12:53:33 UTC 2014

Erich Dollansky <erichsfreebsdlist at alogt.com> wrote:
> On Sun, 12 Jan 2014 04:53:03 -0600
> Scott Bennett <bennett at sdf.org> wrote:
> > Erich Dollansky <erichsfreebsdlist at alogt.com> wrote:
> > 
>  >
> > > I only installed 9.2 once but did not face any problems with MBR.
> > >
> >      Did your boot drive have a MBR on it?  Or a GPT label?
> > 
> it was also MBR and not GPT. But I made a fresh install and did not do
> an upgrade via sources.
     Hmmm...  Did the stage 2 boot loader change in some important way for
i386 between 8.x and 9.2?  I would not have thought that putting stuff into
/dev would have depended upon anything in the loader.  Other than the loader,
what else does installkernel leave unchanged?
     BTW, I just realized that I forgot to mention in my original message
that the first 9.2-RELEASE kernel I tried was built with both

options		GEOM_PART_GPT


options		GEOM_PART_MBR

When that didn't work, I tried commenting out the first of those (GPT), which
was the way I had had them in my 8.2-STABLE kernel.  The change made zero
difference that I could see.  The messages at the point of failure were the
same either way.

                                  Scott Bennett, Comm. ASMELG, CFIAG
* Internet:   bennett at sdf.org   *or*   bennett at freeshell.org   *
* "A well regulated and disciplined militia, is at all times a good  *
* objection to the introduction of that bane of all free governments *
* -- a standing army."                                               *
*    -- Gov. John Hancock, New York Journal, 28 January 1790         *

More information about the freebsd-questions mailing list