freebsd 10.0 RC upgrade disabled many System functions

Aravind Gopal myaravindg at
Sat Jan 11 17:38:29 UTC 2014

I upgraded my system from freebsd 9.2 to 10.0 rc5.
I am using the kde desktop. Hardware:AMD phenomX4 840 on HD 4290 IGP.
For upgrade the commands used are(as given in the release anouncement.

1. freebsd-update upgrade -r 10.0-RC5

As I am not aware of the questions (also dont know where to find the
answers), I replied 'yes' for the questions.

2. freebsd-update install

3. shutdown -r now

4. freebsd-update install

As recommended, I tried to rebuild and install all applications by
using 'portmaster -f' command.
But failed , systen replied that no such command. also no man files.
tried to install pkg_add ­-r portmaster ; syatem replied that
'pkg_add' ­not found.
As this stem failed. went to the next step.

5. shutdown -r now

6. freebsd-update install

At this time internet connection failed, firefos not loading, Rekong
shows the message

 "cannot initiate the Http protocol"

On reboot KDE failed to load and the following messages were seen

"X Server died during start up"

"X Server for display:0 cannot be started, session disabled"

 How to fix this problem, and how to prevent this failure again.

Sorry I am new and learning freeBsd. searched Hand book, but didn't
got the solution.

Please help

Aravind Gopal

More information about the freebsd-questions mailing list