sane - scanimage asks for password

dgmm freebsd01 at
Thu Jan 9 00:31:17 UTC 2014

Hi folks,

I just used sane recently for the first time in some while.  I do regular 
portsnap/portupgrade and something has changed with sane since I last used it.  
When I run scanimage it asks for the users password on localhost.

From the command line, that's not a big deal but running Gimp from the desktop 
causes Gimp to stop when initialising the xsane plugin.  That can be worked 
around by running Gimp from a terminal but I'd much rather know why scanimage 
is asking for the password and how to either stop it asking or set it up to it 
knows how to read the password.

The installer and man page both list some info which I either don't understand 
or am simply getting wrong.

My main interest at this stage is finding out what "resource" is in 

man page and googling around only tells me that ~/.sane/pass is line of the 
format user:password;resource but I don't know what resource ought to be.

The user is in group operator and devfs.rules assigns group operator to 
/dev/ugen4.2 and dev/usb/4.2.0, mode 0666

%cat /usr/local/etc/devd/saned.conf 
notify 100 {
        match "system" "USB";
        match "subsystem" "INTERFACE";
        match "type" "ATTACH";
        match "cdev" "ugen[0-9].[0-9]";
        match "vendor" "0x04A9";
        match "product" "0x1908";
        action "chown -L dave:dave /dev/$cdev && chmod -L 660 /dev/$cdev";

(The chown line has been tried with operator:operator, root;operator, 
saned:saned and dave:saned etc)

scanimage -L
Password for dave on localhost? 
device `pixma:04A91908' is a CANON Canoscan 9000F multi-function peripheral

Any helpful pointers gratefully accepted.

More information about the freebsd-questions mailing list