bsd.openssl.Mk problem

brian brian at
Mon Dec 29 07:27:36 UTC 2014

i have been having a problem with portupgrade -a on a 10.1-i386 system 
that is running pkg that I solved tonight and thought I would pass it along.

I was getting numerous repeats of the below error when I ran portupgrade -a
# portupgrade -a
[Reading data from pkg(8) ... - 54 packages found - done]
make: "/usr/ports/Mk/" line 98: warning: Couldn't read 
shell's output for "/usr/local/sbin/pkg-static  which -qo 
/usr/local/lib/ || :"

Looking at the file:
:/usr/local/lib # ls -l*
lrwxr-xr-x  1 root  wheel       14 Aug 21 06:29 ->
-r--r--r--  1 root  wheel  1808842 Aug 21 06:29

I checked to see if it came from a port, and it seems it didn't.
:/usr/ports # pkg which /usr/local/lib/
/usr/local/lib/ was not found in the database
:/usr/ports # pkg which /usr/local/lib/
/usr/local/lib/ was not found in the database

At any rate, once I installed the openssl package v 1.0.1_16 and the 
problem no longer appears.


More information about the freebsd-questions mailing list