pkg versions don't match

Alejandro Imass aimass at
Fri Dec 19 04:49:19 UTC 2014


I am new to pkg and using a relatively recently installed 10.0-RELEASE.
Today I tried installing and upgrading stuff and the pkg versions on differ from those that pkg finds.

I tried pkg update, etc. but everything says up to date. nevertheless the
versions in:

Do not match. Look at this example:

root at poseidon:/etc/pkg # pkg search fail2ban

root at poseidon:/etc/pkg # pkg install py27-fail2ban
Updating FreeBSD repository catalogue...
FreeBSD repository is up-to-date.
All repositories are up-to-date.
The following 6 packages will be affected (of 0 checked):

New packages to be INSTALLED:
        py27-fail2ban: 0.9.0_2
        python27: 2.7.8_4
        python2: 2_3
        py27-setuptools27: 5.5.1
        py27-sqlite3: 2.7.8_5
        sqlite3: 3.8.6

The process will require 68 MB more space.
10 MB to be downloaded.

Proceed with this action? [y/N]: y
Not Found

In effect the correct version should be py27-fail2ban-0.9.1.txz

How to I update the local pkg db? I updated ports collections thinking they
were somehow related but nothing. I don't know what else to do.

Thanks for any pointers.

Alejandro Imass

More information about the freebsd-questions mailing list