Has the Procedure for Regenerating A FreeBSD Installation Disk Changed?

Roland Smith rsmith at xs4all.nl
Mon Aug 25 19:47:33 UTC 2014

On Mon, Aug 25, 2014 at 08:42:57AM -0500, Martin G. McCormick wrote:
>  Roland Smith writes:
> > Although I don't have FreeBSD-9.1-RELEASE-amd64-disc1.iso around, I 
> > tried
> > the
> > tar command with FreeBSD-10.0-RELEASE-amd64-disc1.iso and that unpacks
> > just
> > fine.
> 	I've got to be doing something wrong. The system I just
> tried this on is
> FreeBSD 9.1-RELEASE-p12 (GENERIC) #0: Tue Apr 29 22:02:25 UTC 2014
> I downloaded the FreeBSD10 image and ran:
> #!/bin/sh
> mkdir headless
>  tar -C headless -pxf FreeBSD-10.0-RELEASE-amd64-disc1.iso

Is this a shell script? What happens when you run the commands in the shell

> This produced a similar flood of "Can't create" errors and it
> doesn't matter in this case if I do this as me or root.

You have enough space, but do you also have enough inodes? You can use “df -ih”
to check that.

Do you perhaps run into other limits, such as open files (login.conf) or disk

Another thing to try is use one or more “-v” flags in your tar command. Maybe
that will yield extra details *why* file creation fails.

> 	I looked up the -C option for tar and it uses the next
> argument as the top of the tree for the file extractions. In
> this case, that is the directory headless and all that is
> working as expected.

Yeah, that should be OK.

R.F.Smith                                   http://rsmith.home.xs4all.nl/
[plain text _non-HTML_ PGP/GnuPG encrypted/signed email much appreciated]
pgp: 5753 3324 1661 B0FE 8D93  FCED 40F6 D5DC A38A 33E0 (keyID: A38A33E0)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20140825/d4402510/attachment.sig>

More information about the freebsd-questions mailing list