operation not permitted on entropy file

David Benfell benfell at parts-unknown.org
Sun Aug 10 22:26:09 UTC 2014

On Sun, Aug 10, 2014 at 11:01:29AM +0200, Polytropon wrote:
> As I'm using a custom kernel, I have set those options:
> 	device smbus
> 	device iicbus
> 	device iicsmb
> 	device iicbb
> 	device iic
> It's probably possible to achieve the same goal using
> loadable modules via /boot/loader.conf. There are some
> "moving parts" involved to get the whole thing working,
> and the default installation does not reflect this. :-)
I haven't looked at the rest of this thread yet, but modules indeed
exist for all of the above. Alas, on my system corresponding devices
still do not.

An additional hardware failure has appeared with one of the lower
speed USB ports. Everything else on that card is still working. I had
unplugged the mouse from that port and now nothing plugged into that
port works (I tried both the mouse and an old Seagate FreeAgent 2TB
drive. The drive subsequently worked when plugged into another low
speed port on the front of the machine.

As to the earlier recommended fsck -fy, I ran it, and indeed had to
empty out /lost+found to get to where I could get a clean pass. I
think I took a lot of these hits in repeatedly reconstructing
databases, but looking over what's left, it looks like some source
files may have been lost from both /usr/src and /usr/ports, so I am
drawing down fresh copies of those trees. The system has now been up

 3:17PM  up  5:30, 4 users, load averages: 0.27, 0.29, 0.36

I'm hopeful. The mess in /var/db/entropy seems a lot more reasonable:

total 80
drwx------   2 operator  operator   512 Aug 10 15:11 .
drwxr-xr-x  24 root      wheel     1024 Aug 10 14:48 ..
-r--------   1 operator  operator  2048 Aug 10 15:11 saved-entropy.1
-r--------   1 operator  operator  2048 Aug 10 15:00 saved-entropy.2
-r--------   1 operator  operator  2048 Aug 10 14:55 saved-entropy.3
-r--------   1 operator  operator  2048 Aug 10 14:44 saved-entropy.4
-r--------   1 operator  operator  2048 Aug 10 14:33 saved-entropy.5
-r--------   1 operator  operator  2048 Aug 10 14:22 saved-entropy.6
-r--------   1 operator  operator  2048 Aug 10 14:11 saved-entropy.7
-r--------   1 operator  operator  2048 Aug 10 14:00 saved-entropy.8

David Benfell <benfell at parts-unknown.org>
See https://parts-unknown.org/node/2 if you don't understand the
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20140810/ef372718/attachment.sig>

More information about the freebsd-questions mailing list