pkg with 9.1RC3

Matthew Seaman m.seaman at
Mon Aug 4 05:40:48 UTC 2014

On 04/08/2014 01:40, doug at wrote:
> Okay, I duplicated my earlier attempt. Last time I ran freebsd-update,
> did a portsnap, and built pkg. This time I skipped all that and just did
> the bootstrap as in the handbook.
> built the system: uname -a
>   FreeBSD 9.1-RC3 FreeBSD 9.1-RC3 #0 r242324: Tue Oct 30
>   00:58:57 UTC 2012
> root at amd64
> My steps:
>   boot pkg
>   pkg2ng
>   pkg install -x perl5
>     Updating repository catalogue
>     No valid repository found.
> I have attached the output of the above. This was the point I decided I
> had to update to 9.1-release and it all worked. This time around, I can
> tell I do not have pkg installed properly as 'pkg help <command>' does
> not work. Any help gives 'No manual entry for pkg-<command>'
> Clearly something is wrong here, but I do not know what I did.

Do you have /etc/pkg/FreeBSD.conf ?  What do you have matching
/usr/local/etc/pkg/repos/*.conf ?

pkg -vv

should show at least one repository listed at the end of the output.



Dr Matthew J Seaman MA, D.Phil.

JID: matthew at

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 1036 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the freebsd-questions mailing list