pkg: sqlite error while executing PRAGMA user_version

Wolfgang Hukriede whukriede at
Sun Aug 3 13:09:34 UTC 2014

Matthew Seaman wrote:

  # pkg shell
  SQLite version 3.8.5 2014-06-04 14:06:34
  Enter ".help" for usage hints.
  sqlite> select * from pkg_lock ;
  sqlite> select * from pkg_lock_pid ;
  sqlite> .quit

Yes, this is what I get.

In the meantime I discovered that "pkg info" works on the diskless box
when invoked as root. I then tried "pkg upgrade -n" and "pkg upgrade".
This worked after some contortions. (It first said "locked", while
the second or third attempt was ok.)

Becoming somewhat more confident I tried a "pkg delete nnn", but
interrupted that with control-c. This seems to have been a mistake,
because now I get "database is locked" consistently and nothing works,
while output for "select * from pkg_lock" is "1|1|0" and "select *
from pkg_lock_pid" returns a number (A pid? But there's no process
with that pid).

Any way to remove to lock? 

Thank you!

More information about the freebsd-questions mailing list