FreeBSD 9.3 new install problems ....

William A. Mahaffey III wam at
Sat Aug 2 21:02:01 UTC 2014

On 08/02/14 13:54, Roland Smith wrote:
> On Sat, Aug 02, 2014 at 09:18:18AM -0500, William A. Mahaffey III wrote:
>>>> I poked around a bit (*not* much), & missed anything RAID-related in the
>>>> installer .... is that on me ? The FreeBSD doc site seemed to imply that
>>>> I would need the shell approach to do what I wanted, so I mostly just
>>>> went w/ that, maybe more pilot error :-/ ....
>>> Personally, to keep things simple I like to install FreeBSD on a simple UFS
>>> partition.
>>> Once the system is up and running I can then mirror/raid the data drives any
>>> way I choose.
>>> There is a wiki page about setting up FreeBSD on a mirrored ZFS boot drive
>>> though;
>>> Roland
>> I tried that & it worked, I am up & running, but on only 1/4 drives. I know
>> ZFS can add drive/providers to stripes or mirrors, how about UFS ?  I can
>> create the stripe for /home & arrange for that to be mounted, but what about
>> root ? Is there a way to create a stripe from 1 or more possibly partitions
>> ? TIA for any more clues ....
> You can create a stripe from devices, not from partitions, AFAICT. See
> gstripe(8). Unlike ZFS (where you can add disks to an existing pool), I don't
> think you can later add devices to an existing gstripe.
> I'd suggest that you create a raidz pool from the remaining devices, and use
> that for whatever filesystems you like. You can have multiple filesystems on
> one zpool, and they will share all the space in the pool.
> Roland

I like ZFS, but I decided that my puny little 25W 1.3 ghz CPU was gonna 
choke on checksums & not get anything else done, hence the switch back 
to UFS. I came up w/ a slightly hairbrained solution. I created a stripe 
of the 3 remaining 20 GB partitions, copied everything under /usr over 
to it, & plan to mount it as /usr. 1 question: as of now, /usr is taking 
up 1.1 GB out of 1.7 GB on my 20 GB root partition. With such a limited 
root FS, I want every available byte available for duty. Is there any 
way to delete what's under /usr on the fly before the mount of the /usr 
stripe to recover that space back for the rest of the install ? I have 
only done the base install as of now, will be installing X, XFCE, LXDE, 
& who knows what else ....

P.S. sorry for me klutzy nomenclature, I am calling /dev/ada0p3 a 
partition, when as you correctly observe it is a device .... my bad, & 
maybe the source of confusion in my posts :-/ ....


	William A. Mahaffey III


	"The M1 Garand is without doubt the finest implement of war
	 ever devised by man."
                            -- Gen. George S. Patton Jr.

More information about the freebsd-questions mailing list