FreeBSD/amd64 on ASUS Transformer T100 kconvertible tablet?

Matthew Pherigo hybrid120 at
Sun Apr 27 02:24:43 UTC 2014

> On Apr 26, 2014, at 8:08 AM, "Alexander Shendi (" <Alexander.Shendi at> wrote:
> I have downloaded FreeBSD-11.0-CURRENT-amd64-VT-20140423-r264794-memstick.img
> from and copied it to an USB memory stick with dd(1).
> As expected the machine did not boot.
> So I have two more questions:
> * I know (by googleing) that a project to support UEFI Firmware boot FreeBSD exists.
> Can anyone point me to a ftp site or other resources.

Hey Alex,

That may not actually be necessary. To my understanding, UEFI supports handling BIOS systems with a mode called the Compatability Support Module. In most PCs, this can be forced on for all attempted boots in the EFI startup options. Moreover, even if this laptop you're working with does not have a setting for this in its options, I know that the process of enabling this mode can be handled by a UEFI boot loader; rEFInd on my Mac handles CSM-mode OSes just fine, even though the Mac itself doesn't have a setting the directly enable it. I've never tried any of this before, but it may be possible to install rEFInd on your EFI part on your laptop first, and install FreeBSD plus its bootloader on it's own partition, at which point rEFInd ought to pick it up. I've never tried this, but it seems that would work fine.

> * Can anyone enlighten me how to mount the memory stick, so I can extract
>  the FreeBSD kernel (under Linux)?

I think 'sudo modprobe ufs' / 'sudo mount -r -t ufs -o ufstype=ufs2' will work. If not, there's always a FUSE module!

More information about the freebsd-questions mailing list