10.0 set prompt for new users has problems

Alberto Mijares amijaresp at gmail.com
Thu Apr 24 15:29:35 UTC 2014

On Thu, Apr 24, 2014 at 10:39 AM, Fbsd8 <fbsd8 at a1poweruser.com> wrote:
> 10.0 host and using pw command to adduser.
> pw adduser test -c Test-user -m -g wheel -w yes
> original /etc/csh.cshrc and /usr/share/skel/dot.cshrc files
> When I log into user test the prompt is a single dollar sign.
> Issuing the ll command i see .cshrc*
> Why does this file end with an *?
> I can edit the as .cshrc* or .cshrc and replace the existing  set prompt
> statement with set prompt = "# %/ >"  then save the file, exit and login
> again. The prompt is still a dollar sign.
> If I issue set prompt = "# %/ >" command from the test user command line
> the prompt still doe's not change.
> I can edit the /usr/share/skel/dot.cshrc replacing the existing set prompt
> with the new one, deluser test, adduser test, and still get dollar sign for
> the prompt even though I see the wanted prompt statement in user test home
> directory .cshrc* file.
> Another problem is the alias commands la and lf don't work but the ll alias
> does work.

Hi Fbsd8,

Last night I experienced a similar issue. As root I added the user jon
to the dialer group

pw groupmod dialer -m jon

In a previously opened shell, with user jon, I found no way to update
this change. I tried executing sh, bash, csh with no success. However,
the change was made. How do you tell the current shell to re-read the

Looks like your issue, don't you think?



Alberto Mijares

More information about the freebsd-questions mailing list