Rolf Nielsen rmg1970swe at gmail.com
Wed Apr 23 23:19:15 UTC 2014

On 2014-04-24 00:35, Julian H. Stacey wrote:
> Rolf,
>     > And I'm sorry for top posting. My mail app doesn't let me put my reply 
>     > below the original message.
>     Though your 2nd, 3rd & 5th posts broke FreeBSD.Org convention
>     	http://www.freebsd.org/doc/en_US.ISO8859-1/articles/mailing-list-faq/etiquette.html
>     Your 4th post was _Correct_ 
>     	http://lists.freebsd.org/pipermail/freebsd-questions/2014-April/257695.html
>     Stick with method used Tue Apr 22 13:56:06 UTC 2014.
> questions@,
> Rolf's last post corrected, & my addition appended:
> Rolf Nielsen wrote:
>> 2014-04-22 20:25 GMT+02:00 Chris Whitehouse <cwhiteh at onetel.com>:
>>> On 22/04/2014 12:07, Thomas Mueller wrote:
>>>> I need to use the USB tethering ability of my Samsung Galaxy S5, and the
>>>>> handbook suggests using either cdce or urndis. I've tried cdce with no
>>>>> luck,
>>>>> and I'm not surprised because windows identifies the phone as RNDIS.
>>>>> However,
>>>>> I can't find any urndis anywhere on my system. Some pointers would be
>>>>> greatly
>>>>> appreciated.
>>>>  Sincerely,
>>>>> Rolf Nielsen
>>>> I remember seeing urndis as an option in NetBSD kernel config, but not
>>>> FreeBSD.
>>>> Here is the line from NetBSD-current i386 GENERIC kernel config:
>>>> urndis* at uhub? port ?         # Microsoft RNDIS specification
>>>> I am not really familiar with this.
>>> urndis man page says it provides support for Ethernet access over Remote
>>> NDIS. Is that what you want? Or do you want to use your phone's 3(/4)g
>>> capability?
>>> I tether my phone to my laptop in the sense that I use it as a modem for
>>> my laptop when I don't have access to wifi or ethernet. I connect the two
>>> with a USB cable and use ppp. The laptop is then using the phone's 3g
>>> connection.
>>> If that's what you want see the handbook:
>>> http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/userppp.html
>>> Sorry if that's off message.
>>> Chris
>> I want to use my phone's 3G/4G capability as an ethernet connection. And I
>> got that working through urndis. I had an outdated prerelease of 10.0, and
>> when I updated the sources and compiled, urndis was installed. When I
>> connect my phone and enble USB tethering, the interface ue0 appears.
> I was puzzled what urndis was, (what with top posting, mentions
> of NetBSD, & no specification of paths in which version of src/
> ports/ lkms or whatever) but it sounded useful so searched:
> Urndis is not in Any FreeBSD release, including 9.2 or 10.0.
> Urndis is just in 9-stable & current.
> /pub/FreeBSD/branches/-current/src/
> /pub/FreeBSD/branches/9.0-stable/src/
> 	share/man/man4/urndis.4
> 	sys/dev/usb/net/if_urndis.c
> 	sys/dev/usb/net/if_urndisreg.h
> 	sys/modules/usb/urndis
> This fails:
>  http://www.freebsd.org/cgi/man.cgi?query=urndis&apropos=0&sektion=4&manpath=FreeBSD+11-current&arch=default&format=html
> This works:
>  nroff -man /pub/FreeBSD/branches/-current/src/share/man/man4/urndis.4
> 	The first FreeBSD release to include it was FreeBSD 9.3
> But is misleading, there is not [yet] a 9.3 Release, only 9.2-RELEASE
> Cheers,
> Julian

I'm on stable, not release. After updating the sources this is the
output of uname -a

FreeBSD lazlar.no-ip.biz 10.0-STABLE FreeBSD 10.0-STABLE #1 r264763: Tue
Apr 22 22:56:11 CEST 2014
root at lazlar.no-ip.biz:/usr/obj/usr/src/sys/TRAPPER  amd64

Before updating, I had something from mid January this year, and
sometime between then and what I'm running now, urndis obviously has
been included. Anyway, my problem is now solved.

And once again I apologise for my previous top postings. I had no
internet connection on my computer (I live in the middle of nowhere, and
I have no landlines of any kind, neither phone nor internet, but
strangely I have excellent 4G connection, hence the need for USB
tethering), and was posting from my phone. The mail client I use on my
phone wouldn't allow me to post properly.


More information about the freebsd-questions mailing list