print/cups: since update to 1.7.1: error : Send-Document client-error-document-format-not-supported

Cary cary at
Sat Apr 19 22:26:06 UTC 2014

Boris Samorodov wrote:
> 14.04.2014 15:58, Alex Dupre пишет:
>> Boris Samorodov ha scritto:
>>> Great, glad to be helpful.
>>> May be the patch is not right and the problem should be resolved
>>> in another way. But anyway the problem seems to be localized and
>>> I'm sure Max will do the right thing.
>> As already said, I fixed the very same problem with hplip installing
>> cups-filter: I don't know which one is the correct way.
> Alex, I've read your previous answer. But didn't reply, ENOTIME, sorry.
> The problem here was when both hplip and cups-filters were installed.

Thank you for the patch.

Before rebuilding hplip-3.14.4 I found that perl would hang
consuming most of the cpu cycles as it tried to start
/usr/local/bin/foomatic-rip using the symlink foomatic-rip-hplip installed in
/usr/local/libexec/cups/filter .

I use cups to access a printer
with a "smb://" uri.  The lp (1) command worked, but
for several months I have not been able
to print from a web browser.  After updates of cups ports and
with the patch for hplip things have improved.
Error messages in the past from cups-1.5 mentioned
the pdftops filter.

cary at
SDF Public Access UNIX System -


More information about the freebsd-questions mailing list