freebsd 10. trashing hard drives?

bill bill at
Wed Apr 16 06:13:35 UTC 2014

I hadn't tried Free BSD since 4.x, but thought i'd give it a go. I 
installed a bootable cd of 10. onto a 300gb sata drive in a 2007 
emachine with 4gb ram. It completed the install and asked to reboot into 
the system. From that point it hangs on the "e" machine logo. Will not 
boot or even go into bios or select boot drive with that hard drive in 
operation. When hard drive is disconnected, it goes to free bsd logo and 
offers to boot into single or multi user mode, etc, though there is no 
hd. Occasionally there is an error that the machine cannot use long mode.

I thought i had mistakenly used the 64-bit when i should have used 
32-bit, though the same setup was happy with Ubuntu Linux 64-bit. 
Sooo... i got a 160gb drive off ebay and tried again using the 32-bit 
install of 10.0. Same result. It seems to install fine, reboots, halts 
at the "e" machine logo, and goes no further. From that point, it will 
not boot from cd, usb, or any other media so long as either hard drive 
is connected. With no hd connected, it brings up the bsd logo and asks 
whether i want single or multi user mode, etc.

In both cases I let bsd use its own default settings without changing 
any. It seems to partition based on the hd being used with small root, a 
swap, and mostly another partition.

Does 10.x assume a TB+ drive and partition accordingly? Is there any 
means, bsd or other, i can get into these hard drives and repartition 
them? As it stands they both seem to have been rendered useless by 
trying to install an OS. Something i have never encountered. Any advice 
most appreciated!


More information about the freebsd-questions mailing list