Issue with upgrade (9.1 to 9.2)

Andre Goree andre.goree at
Wed Apr 9 20:12:07 UTC 2014

To answer your question, I was able to mount all the partitions and
chroot in with 'chroot /tmp/mnt /rescue/sh", however, any command I
would type after chroot'ing in would produce this error:

ELF interpreter /libexec/ not found
Abort trap

Even though that file indeed exists.

On Wed, Apr 9, 2014 at 4:08 PM, Andre Goree <andre.goree at> wrote:
> FWIW, even copying from /libexec with the 9.2-RELASE iso did not work.
>  I'll probably just install...kinda sucks that I used freebsd-update
> for this -- I should've just built it like I would normally do, though
> I'm not certain that would've changed anything.
> On Wed, Apr 9, 2014 at 2:03 PM, Thomas Hoffmann <trh411 at> wrote:
>> On Wed, Apr 9, 2014 at 12:16 PM, Andre Goree <andre.goree at> wrote:
>>> Anyone have any insight on this?  Is there any way to salvage this or
>>> am I just SoL and need to reinstall?
>>> On Tue, Apr 8, 2014 at 10:51 PM, Andre Goree <andre.goree at>
>>> wrote:
>>> > It would seem I've screwed something up with my upgrade.  Soon after
>>> > performing the upgrade via freebsd-update followed by a reboot, I
>>> > tried to go into single-user mode to finish up.  After doing so,
>>> > everytime I attempted to use my /usr partition, I would run into the
>>> > error:
>>> >
>>> > /var: got error 11 while accessing filesystem
>>> >
>>> > I [thought] I fixed this by following this[1] mailing list post, which
>>> > suggested upping 'kern.bio_transient_maxcnt'.  I set that tunable to
>>> > 10 and rebooted, at which point the server appeared to boot fine.  I
>>> > think continued with 'freebsd-update install', however apparently it
>>> > was interrupted -- probably with a kernel panic as my system
>>> > automatically rebooted and was thrown to single-user mode.  Now, the
>>> > issue is that in single-user mode, I cannot access any shell, I get
>>> > the following error:
>>> >
>>> > ELF interpreter /libexec/ not found
>>> >
>>> > I recall running into this on a different box a year or two back...I
>>> > think I had to somehow run ldconfig, but in this case I cannot as even
>>> > when I boot with a live cd and mount my partitions, when I try to
>>> > chroot I run into that same error.  Help?
>> Can you access the rescue shell at /rescue/sh? /rescue contains statically
>> linked commands for just such a contingency as this. If that works, maybe
>> you can then copy from ./libexec from the live CD to your base
>> system (/libexec) to get past this issue?
>> -Tom
>> _______________________________________________
>> freebsd-questions at mailing list
>> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list