USB keyboard in FreeBSD 10 amd64 installer

Joshua Lokken jrlokken at
Tue Apr 8 04:07:32 UTC 2014

I've have tried about everything possible at this point:

I use onboard audio, so no -- nVidia chipset for the NIC, audio and USB,
all are ON.  USB works just great, until the installer screen loads -- all
I can do consistently is Ctrl-Alt-Del to reboot, no other keypresses
generate any signal.

In fact, I just tried with a PS/2 keyboard, and I've used those with
FreeBSD forever, and _never_ had a problem.  Same behavior in this case, no
keypresses work except for Ctrl-Alt-Del.

I've cleared the CMOS and meticulously gone through every setting, nothing
I've found works so far.

I just dl'ed the i386 iso, just to test, but I've run out of blank media
for the immediate time being, so I'll have another go at it tomorrow.

Does anyone know of any way to get past this installer screen without a
working keyboard?  Or is there another installation method I could
attempt?  Thanks again.


On Mon, Apr 7, 2014 at 8:44 PM, Matt Bettinger <iamatt at> wrote:

> Did you disable audio in the bios?  On an Intel mini atx system I have the
> onboard nic and  USB would not work with audio device disabled, yeah.
> On Apr 7, 2014 9:53 PM, "Erich Dollansky" <erichsfreebsdlist at>
> wrote:
>> Hi,
>> On Mon, 7 Apr 2014 19:43:06 -0700
>> Joshua Lokken <jrlokken at> wrote:
>> > There are 3 USB-related BIOS options, basically:
>> >
>> > USB On/Off
>> > Legacy USB On/Off
>> > USB Mass Storage On/Off
>> >
>> > I tried with Legacy USB both on and off, same results.  I checked the
>> > mobo manual, and all ports are USB 2.0/1.1, no BIOS updates available.
>> >
>> Some keyboards need the legacy stuff. As all your ports are USB 2, it
>> has to work.
>> Erich
>> _______________________________________________
>> freebsd-questions at mailing list
>> To unsubscribe, send any mail to "
>> freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list