FreeBSD 8.4 Boot failure

Terje Elde terje at
Wed Sep 25 06:45:31 UTC 2013

On 25. sep. 2013, at 06:59, Tyler Sweet <tyler at> wrote:
> I tried reinstalling the boot blocks from both
> the fixit live filesystem and also mounting zroot and using the files
> there in case they were different.

Disclaimer: I haven't gotten (enough) morning-coffee yet, but...

Disclaimer 2: at times tracking how zfs-booting is done in the different versions can be a bit tricky. This is a moving target, and I've lost track of the 8-branch. 

That said, assuming you have the correct bootcode (gptzfsboot), here's what might have happened:

You installed 8.2, with a loader supporting zfs. Then you upgraded your /boot-stuffs, and bootcode on disk (correctly), but got left with a loader without zfs support. Then tried to upgrade the bootcode, but you're still left with a loader not supporting zfs. 

If I recall correctly, then the zfs-bootcode for 9+ will use "zfsloader" (supporting zfs and built by default), while earlier versions depend on "loader" with zfs support (built without by default). 

If that's the case, you could dump LOADER_ZFS_SUPPORT into /etc/make.conf and rebuild/reinstall it, or install /boot/loader from the fixit (if it has zfs support in 8.4). 

That's my first thought at least... If that  doesn't fix it (remember backups of any files you replace or upgrade), it'd be interesting to see the output of:
ls -l /boot/*loader /boot/*boot
On the /boot you're using. Anything that didn't get built or installed?

Also, did you snapshot your zfs before upgrading? Could be a working /boot/loader there, which might be the easiest way to get the system up, before rebuilding with ZFS-capable loader... if I'm right, which isn't a given (ref disclaimers). 


More information about the freebsd-questions mailing list