Shared object "" not found, required by ""

Antonio Olivares olivares14031 at
Wed Sep 11 20:03:34 UTC 2013

Dear folks,

I am having problems with subject line.  I have to fix error by
reinstalling subversion, but it keeps coming back with this error

Shared object "" not found, required by ""

===>>> Returning to list of ports depending on subversion-1.8.3

===>>> Updating done for ports that depend on subversion-1.8.3

===>>> The following actions were performed:
    Re-installation of subversion-1.8.3
    Re-installation of portshaker-1.0.8
    Re-installation of portshaker-config-1.0.8

===>>> Exiting

I did a

#  portmaster -d -r subversion

I configured subversion to use serf because I am used to freebsd_texlive_*

I run to update and I get

[Info  19:57:22] Updating 'freebsd_texlive' source ports tree with method 'svn'.
Shared object "" not found, required by ""
[Error 19:57:22] Subversion update failed.
[Error 19:57:22] Failed to update the 'freebsd_texlive' ports tree.

machine has not been updated since 05/27, I read entry:

  AFFECTS: users of devel/subversion
  AUTHOR: ohauer at

  devel/subversion has been upgraded from 1.7.10 to 1.8.0

  If you want to upgrade, and use http/https access to repositories,
  please check, that the SERF option is enabled, as NEON support
  is gone. Also, mod_dontdothat and svnauthz_validate are
  now enabled with one option TOOLS, among other new tools
  and SVNMUCC is enabled always.

  subversion-1.7.x is available as devel/subversion17

  To stay on subversion-1.7.x set in /etc/make.conf
  and use the following command

  # pkg set -o devel/subversion:devel/subversion17


  # portmaster -o devel/subversion17 devel/subversion

I configured subversion to use serf option and tried it.

Thanks for advice/ideas & suggestions.

Best Regards,


More information about the freebsd-questions mailing list