click-click in floppy disk drive

leeoliveshackelford at leeoliveshackelford at
Thu Oct 24 18:26:37 UTC 2013

Many thanks to Polytropon, Warren Block, and others for their time and effort to respond to my inquiry concerning the continual clicking at 2 second intervals of the u.s.b. floppy disk drive on my Hewlett-Packard z220 workstation running FreeBSD 9.1. As was suggested to me, I ran the lsof utility.  It created a very long text file, which unfortunately, I was unable to interpret.  I ran the "mount -v" command.  It did not indicate that a floppy drive was mounted.  I inserted a diskette into the drive, and mounted it.  The mount was successful.  The clicking continued, but each click was then followed by rotation of the diskette.  I ran ls command on the floppy disk, which resulted in a correct display of the directory.  However, when I ran the umount command, the system responded that the device was busy, and therefore could not be unmounted.  I ran the command "camcontrol devlist" followed by "camcontrol reset n:0:0".  The floppy drive kept on clicking.

Polytropon's comment on Oct. 22 at 15:42 P.D.T. that I had in fact successfully installed the operating system is technically true.  However, my idea of a fully functioning workstation includes the addition of applications that will allow me to get work done.  I would like my system include the installation of X-windows, Gnome, and Open Office.  My problems in this area are described in another thread, "Gnome green screen of death" on September 26 19:34 P.D.T.  That installation effort was based on the incorrectly informed notion that if I entered the command "pkg_add gnome2" that the system would take care of loading and configuring all other packages on which gnome depends.  After that fiasco, I uninstalled gnome, and have ever since been trying to install and then configure each underlying package in my idea of the order of dependency.  All of my printers are Hewlett-Packard lasers.  First, I installed cups.  I was flummoxed because the instructions to configure cups requi
e the use of a web browser, which I do not yet have.  Then I installed hplip, which I could not configure because cups was not configured.  Subsequently, I have been trying to install xorg.  It does not work because I have two video drivers, but only one monitor.  I have found in the archives several questions about this state of affairs, but the responses were too general for me to follow, that is, to implement the instructions given would require skill and experience that I do not yet have to be able to fill in all of the little details that were missing but assumed to be understood.

Returning to the floppy disk drive, when I ran "camcontrol stop n:0:0", the system responded by erasing the command, and moving the cursor leftward to the prompt.  It is possible that the system redisplayed the list of parameters to this command, and then redisplayed the prompt, and that by chance the new prompt was at the exact location of the old prompt.  It is also possible that I did not see the screen re-write due to the behavior of the graphics accelerator, even though the screen is written in character mode.

As I was falling asleep the other night, I remembered that the problem with the floppy drive began after I had modified the file /etc/rc.conf.  The instructions for installation of xorg say to add the following two lines to this file:  "hald_enable="YES", and "dbus_enable="YES".  The clicking begins as soon as the login prompt appears.  The last several lines that are written to the screen preceding the login prompt are as follows:

Creating and/or trimming log files.
Starting syslogd.
No core dumps found.
Clearing /tmp (X related).
Starting hald.
Starting dbus.
Updating motd:.
Starting ntpd.
Configuring syscons: blanktime.
Starting sshd.
Starting cron.
Starting background file system checks in 60 seconds.
[blank line]
[date and time]
[blank line]
FreeBSD/i386 [name of computer] (ttyv0)

After logging-in as toor, I entered the following commands.  The comments describe the result.

service hald stop [enter]
# The clicking stops.
service hald start [enter]
# The clicking resumes.
service dbus stop [enter]
# The clicking stops.
service dbus start [enter]
# The floppy disk drive remains silent.

Based on this discovery, I realize that my problem could be sidestepped by writing a login script that stops, and then restarts dbus, but I wish I could have a little clearer understanding of what is going on here.  Also, at this point in time, I have no training in writing sh or bash scripts.  What are hald and dbus supposed to do?  Are they being started with incorrect parameters?  Are they being started in an incorrect order relative to other daemons that are started by the system?  There was no change in behavior when I interchanged the order of hald_enable and dbus_enable in the /etc/rc.conf file.  In which order are /etc/rc.conf, /etc/defaults/rc.conf, and other possible startup files executed?  Which file contains the instruction to write the login prompt?

As before, any and all comments are most appreciated.  Yours truly, Newby Lee

More information about the freebsd-questions mailing list