click-click in floppy disk drive

Polytropon freebsd at
Tue Oct 22 21:00:09 UTC 2013

On Mon, 21 Oct 2013 13:56:05 -0700 (PDT), leeoliveshackelford at wrote:
> Good afternoon, dear FreeBSD enthusiast.  I have recently
> installed FreeBSD 9.1 on my Hewlett-Packard Z220 workstation. 
> I added a Sabrent u.s.b. floppy drive.  Two days ago, I ran
> the "periodic" program. 

The "periodic" facility is just a collection of scripts for
cron that get run at specific intervals. Are you referencing
to the stock system's /etc/periodic scripts or did you add
any custom scripts?

> Ever since then, the floppy drive clicks once every 2 seconds,
> followed by a double blink of the hard drive light. 

This indicates a disk access. Do you maybe have an umount
pending? You can physically remove the disk while it is
mounted. Maybe something still tries to determine free disk
space (or something like that) for a floppy that is no
longer in the drive? Check the output of "lsof" as well
as of "mount -v" for any suspicious entries.

I've tried with an IBM USB floppy disk drive:

ugen2.2: <TEAC> at usbus2
umass1: <TEAC TEAC FD-05PUB, class 0/0, rev 2.00/0.00, addr 2> on usbus2
da3 at umass-sim1 bus 1 scbus4 target 0 lun 0
da3: <TEAC FD-05PUB 3200> Removable Direct Access SCSI-0 device 
da3: 1.000MB/s transfers
da3: Attempt to query device size failed: NOT READY, Medium not present

When given the null command, the device doesn't do anything;
"true > /dev/da3" and ": > /dev/da3" don't make it show any
activity. If I insert a disk, the drive gets active and the
null command at least causes some action. Of course I can
then access the floppy in the drive. Without any access, the
drive will not show any further activity, no matter if there's
a floppy inside or not.

> The is no disk in the floppy drive.

That could be the reason. Try inserting a floppy and see if
it satisfies the system. :-)

> Does anyone know how to stop this annoyance?

I'd say the easiest way is to disconnect the drive, and then
later on reconnect it.

If that's not possible, you could use the "camcontrol" command
to reset the channel where the floppy drive is attached to.
Check "camcontrol devlist" to see which channel it is.


# camcontrol devlist
<HL-DT-ST DVDRAM GSA-H42N RL00>    at scbus0 target 0 lun 0 (pass0,cd0)
<HL-DT-ST DVD-ROM GDR8163B 0L30>   at scbus0 target 1 lun 0 (pass1,cd1)
<Generic Flash HS-CF 4.55>         at scbus3 target 0 lun 0 (pass2,da0)
<Generic Flash HS-MS/SD 4.55>      at scbus3 target 0 lun 1 (pass3,da1)
<Generic Flash HS-SM 4.55>         at scbus3 target 0 lun 2 (pass4,da2)
<TEAC FD-05PUB 3200>               at scbus4 target 0 lun 0 (pass5,da3)

In my case, I would have to "camcontrol reset 4:0:0". Also
see "man camcontrol" for details, for example to find other
commands like "stop" that could be sent to the floppy drive
to make it stop clicking.

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list