9.1 - 9.2 upgrade

Doug Hardie bc979 at lafn.org
Wed Oct 9 09:52:49 UTC 2013

On 8 October 2013, at 16:40, Polytropon <freebsd at edvax.de> wrote:

> On Tue, 8 Oct 2013 11:20:40 -0700, Doug Hardie wrote:
>> I tried downloading the src with:
>> svn co https://svn0.us-west.FreeBSD.org/base/releng/9.2 /mnt/usr/src
>> I didn't get Release 9.2. The first entry in UPDATING is:
>> 20130705:
>>        hastctl(8)'s `status' command output changed to terse one-liner format.
>>        Scripts using this should switch to `list' command or be rewritten.
>> There is an entry earlier for Release 9.1. but no entry for Release 9.2.
> You could try downloading and extracting the "src" distribution:
> ftp://ftp.freebsd.org/pub/FreeBSD/releases/i386/9.2-RELEASE/src.txz

Before I saw this I built from the src obtained via svn.  The system now boots.  I still have no idea what was preventing it from booting.  It was something between displaying the Beastie menu and waiting for user input.  There had to be at least 2 issues as the messages changed after the first attempt to rebuild the system.  I tried to chase down the boot code for the first error message and it appears to be generated when there is a problem with a directory.  I couldn't find any further diagnostic info to identify the directory.  I have not yet tried to chase down the second set of messages in the source.

The system now says its 9.2.  UPDATING still looks the same.  Interestingly enough, on another system that I updated earlier to 9.2 via freebsd-update, UPDATING there is identical to the one on this system.  There is no 9.2 entry.  

Also of note is that most of the ports/packages are still present.  However SASL2 vanished without a trace.  Its easily replaced, but why is certainly interesting.  I have no ideas at this point.

More information about the freebsd-questions mailing list