failed to create gmirror with the handbook instructions

Andy Zammy andyzammy at
Tue Oct 8 18:49:34 UTC 2013

This is actually trickier than it first looked. First I got into single
user mode by supplying 'shutdown now', but the tunefs commands all failed
with the following:
#tunefs -j disable /dev/ada0s1a
Clearing journal flags from inode 4
tunefs: Failed to write journal inode: Operation not permitted
tunefs: soft updates journalling cleared but soft updates still set.
tunefs: remove .sujournal to reclaim space
tunefs: /dev/ada0s1a: failed to write superblock

I tried the dump command on the off-chance, and it failed with the original
errors. Is there anything you can recommend?

I then noticed you specified to boot into single user more, so I restarted
the machine, with only ada0 attached. Because the handbook wants me to use
the mirror/gm0sX devices, I swapped my fstab file back to the original. The
boot loader now only seems to recognise the mirror/gm0 nodes, the original
ada0sX are gone (though ada0 still shows up). I'm not sure if it's
acceptable to do the dump by booting the 1st hard drive using the
mirror/gm0, and then dump to the 2nd hard drive by mounting what will be
ada1sX. Is this okay to do?

On 8 October 2013 01:31, Warren Block <wblock at> wrote:

> On Tue, 8 Oct 2013, Andy Zammy wrote:
>  Hi,
>> I used the second section of the handbook (20.4) to create a gmirror. In
>> my
>> particular setup I had a 1GB /, 6GB swap, 1GB /tmp and the rest of the 1TB
>> drive was left for /usr
>> I had to deviate from the handbook when it came to running the dump +
>> restore commands, as the dump failed due to an issue with the journalling.
>> To get around this problem, I dropped into single user mode, so I could
>> remount root as read-only. The dump commands then worked. It specified in
>> the handbook to restart the machine, and boot from ada1.
>> It was at this point that I noticed something wasn't quite right. There
>> was
>> a spew of 'not found/no such file or directory' messages. These were all
>> trying to reference libs and binaries that live in /usr.
>> I boot into single user mode, and upon checking the other partitions, I
>> notice that /tmp and /usr are empty, apart from a .snap file, and the
>> restoresymtable file.
>> Please could someone help me troubleshoot this problem? Let me know if you
>> need any more info, and I'll post it up asap.
> dump does not work reliably on filesystems with SUJ enabled.  Turn off SUJ
> on the filesystems to be dumped by booting in single-user mode and running
>   tunefs -j disable /dev/ada0whatever
> Do each filesystem, then use dump.

More information about the freebsd-questions mailing list