FreeBSD 9.2-RELEASE stability?

other at other at
Tue Oct 1 23:54:33 UTC 2013

On Mon, Sep 30, 2013, at 14:01, Brett Glass wrote:
> How stable are folks finding FreeBSD 9.2-RELEASE to be? The
> improvements are welcome, but there have been a few troubling
> messages about kernel panics and VM issues on the various mailing
> lists. It's never clear until the release drops whether these are
> actual problems with the software or hardware defects in individual
> systems, so I am eager to hear how the new release is working for
> everyone.

very frustrated at the moment...

I've had some very strange issues crop up since upgrading from 

I'm using FreeBSD on a Xen HVM instance. My previous install was a 
system with a custom kernel
(includes Xen HVM options) (entire base and kernel compiled with Clang 
3.1 (base clang)).
The system worked flawlessly.

A "rinse and repeat" upgrade (build from source) with 9.2 is giving me 
some very strange issues:

* Randomly when I start the VM, there is no network connectivity. I 
first noticed DHCP was timing
out. The link appeared to be up on the xn0 interface but no data flow 
at all. Attempted manual
interface configuration. Zilch, couldn't even get a response from the 
default gateway when pinging
(both ipv4 and ipv6). A reboot of the machine and suddenly network 
connectivity is restored. Subsequently
with no predictability, another reboot = no network again. No errors in 
dmesg or /var/log/messages.

* /usr/ports/net/net-im/jabber (which appears not to have changed 
versions between my system upgrade) randomly
aborts with signal 10 (bus error).....

* Programs that rely on mysql (installed percona 5.5 server) (such as 
jabber, powerdns etc) spew a bunch of errors saying they are unable
to connect to the mysql server via /tmp/mysql.sock, after I log in and 
look, mysql is running just fine, and the programs
that were complaining about mysql being unreachable are all operating 
correctly... (i have mysql set to start in /etc/rc.d before any of
the programs that require it are started) -- never saw these issues in 

* I run powerdns recursor for resolution of domain names. Despite 
having the recursor as being one of the first things
in rc.conf to start (certainly before ntpdate), ntpdate decides to run 
before the recursor has started. This causes the lookup of the ntp 
hostname to fail (using -b ip.ip.ip.ip as a flag to ntpdate rather than 
a host is a way to work around the issue).

This was a clean build. I cleared up old libraries and rebuilt all my 
installed ports from scratch, I left no
kruft lingering on the system to the best of my knowledge.

Normally I would put something like the jabber server issue just being 
bad code that clang is happy to compile.. But the
random network issue has the alarm bells ringing. Perhaps there is an 
issue with clang 3.3 generating faulty code?

I havent had any kernel panics or machine freezes.

This has to be a first for me with freebsd, I almost never ever have an 
issue after upgrading from RELEASE to RELEASE.

I can probably rebuild it all again with the base gcc compiler, but 
clang is much much faster than the dinosaur gcc included in
base and produces better code. Up in the air with this one. I might go 
back to 9.1, had none of these issues with it.

/my 10 cents worth.


More information about the freebsd-questions mailing list