TERM / termcap / terminfo & st from suckless tools

illoai at gmail.com illoai at gmail.com
Thu Nov 21 17:54:16 UTC 2013

On 21 November 2013 12:38, Sean DuBois <sean at siobud.com> wrote:

> On Thu, Nov 21, 2013 at 09:27:14AM -0500, Rob Paisley wrote:
>> I use st 0.4.1 from st.suckless.org as my terminal. It assigns
>> TERM=st-256color. Accordingly I get errors running top / tmux as follows:
>> $ top
>> top: can't open termcap file
>> $ tmux
>> open terminal failed: can't find terminfo database
>> On Linux like systems, the solution is:
>> $ tic -s st.info
>> 2 entries written to /home/rpaisley/.terminfo
>> which is run normally via make install. On FreeBSD 9.2-RELEASE with `pkg
>> install ncurses` yielding version 5.9_3, the output is as follows:
>> $ tic -s st.info
>> 2 entries written to /usr/local/share/misc/terminfo.db
>> It didn't appear to have changed in size, so I ran the same command as root
>> and verified the file /usr/local/share/misc/terminfo.db did in fact change,
>> yet I still get the errors from above for both top / tmux.
>> My current work around is to manually set TERM=xterm-color.
>> I've tried various settings for TERMINFO / TERMCAP environment variables to no
>> avail. How do I get st-256color recognized as a valid terminal?

> This might not be any help, but I have been setting termname to
> xterm-256color in my config.h for as long as I have used st.
> (the port allows you to pass in your config.h easily, so don't
>  download from suckless.org if you don't plan on patch/dev)
> I have issues with working on remote machines when setting my TERM to
> anything else. (I don't want to install st everywhere I go) this has
> been the case for me on both GNU/Linux and FreeBSD
> I use vim, emacs, mutt and ncmpcpp locally + remote in tmux and I have
> not had any issues with my setup.
> The only thing I have run into is issues with mutt, and to fix that use
> slang instead of ncurses and set the env var CLICOLOR=yes

Resorted to rxvt-256color, because, despite toe -a showing st-256color,
it simply doesn't work.  (toe also dumps core, so there's that)
> tic -c /usr/local/share/misc/terminfo.db
"/usr/local/share/misc/terminfo.db", line 18, col 1: Illegal character
(expected alphanumeric or @%&*!#) - '^C'


More information about the freebsd-questions mailing list