TERM / termcap / terminfo & st from suckless tools

Rob Paisley paisley at rpaisley.com
Thu Nov 21 14:35:05 UTC 2013

I use st 0.4.1 from st.suckless.org as my terminal. It assigns
TERM=st-256color. Accordingly I get errors running top / tmux as follows:

$ top
top: can't open termcap file

$ tmux
open terminal failed: can't find terminfo database

On Linux like systems, the solution is:

$ tic -s st.info
2 entries written to /home/rpaisley/.terminfo

which is run normally via make install. On FreeBSD 9.2-RELEASE with `pkg
install ncurses` yielding version 5.9_3, the output is as follows:

$ tic -s st.info
2 entries written to /usr/local/share/misc/terminfo.db

It didn't appear to have changed in size, so I ran the same command as root
and verified the file /usr/local/share/misc/terminfo.db did in fact change,
yet I still get the errors from above for both top / tmux.

My current work around is to manually set TERM=xterm-color.

I've tried various settings for TERMINFO / TERMCAP environment variables to no
avail. How do I get st-256color recognized as a valid terminal?

More information about the freebsd-questions mailing list